Posted in Mac Apps

Update Your Apple Pro Apps to Prepare for macOS High Sierra

On Aug 18 Apple published an document to notify its customers that earlier versions of Apple Pro apps – including Final Cut Pro, Logic Pro, Motion, Compressor, and MainStage – may not be compatible with macOS High Sierra, the upcoming fourteenth major release of macOS. Customers who are using the older version need to update these apps if they would like to run macOS High Sierra after this fall.

Continue reading “Update Your Apple Pro Apps to Prepare for macOS High Sierra”

Advertisements